Cara Backup Mikrotik lewat FTP

      No Comments on Cara Backup Mikrotik lewat FTP
Script Auto Backup dengan FTP Mikrotik
Script Auto Backup dengan FTP Mikrotik

Dalam teknologi informasi, backup adalah proses membuat data cadangan dengan cara menyalin atau membuat arsip data komputer sehingga data tersebut dapat digunakan kembali apabila terjadi kerusakan atau kehilangan.[1]

Backup memiliki dua tujuan. Tujuan utama adalah untuk mengembalikan data apabila data tersebut hilang, baik karena terhapus atau karena rusak (corrupt). Tujuan kedua adalah untuk mengembalikan data ke titik tertentu pada masa lalu.

Karena fungsinya, proses backup mengharuskan pengguna menggandakan data, yang akhirnya menghabiskan kapasitas media penyimpanan. Ini mendorong ditemukannya teknologi-teknologi untuk mengefesienkan penyimpanan data backup, misalnya deduplikasi dan kompresi.

Berikut hal hal yang harus di persiapkan

  1. FTP Server untuk mengisi FTPServer
  2. Akun FTP untuk mengisi FTPUser dan FTPPass
  3. Lokasi untuk FTPLocal

Yap langsung aja, langkah pertama yang harus di lakukan buat halaman script baru kemudian beri nama misalnya autoBackup.

Silahkan copy n paste script dibawah ini, dan disesuaikan parameter FTPServer FTPUser FTPPass dan FTPLocal nya. Klik OK untuk menyimpan scriptnya.

Langkah selanjutnya Buat Scheduler  baru backupnya untuk menjalankan script secara berkala. Tuliskan nama script tadi autoBackup pada On Event Silahkan atur interval waktunya. Klik OK untuk menyimpan.

Goooood Luccccckkk !

Catatan: FTP host user dan password dan dir nya haruslah tepat. Karena jika salah file tidak akan terkirim !

RouterOS Script

:local saveUserDB true
:local saveSysBackup true
:local encryptSysBackup false
:local saveRawExport true

:local FTPServer "*****"
:local FTPPort 21
:local FTPUser "******"
:local FTPPass "******"
:local FTPLocal "*****"


:local ts [/system clock get time]
:set ts ([:pick $ts 0 2].[:pick $ts 3 5].[:pick $ts 6 8])

:local ds [/system clock get date]
:set ds ([:pick $ds 7 11].[:pick $ds 0 3].[:pick $ds 4 6])

:local fname ("BACKUP-".[/system identity get name]."-".$ds."-".$ts)
:local sfname ("/".$fname)

:if ($saveSysBackup) do={
:if ($encryptSysBackup = true) do={ /system backup save name=($sfname.".backup") }
:if ($encryptSysBackup = false) do={ /system backup save dont-encrypt=yes name=($sfname.".backup") }
:log info message="System Backup Finished"
}

if ($saveRawExport) do={
/export file=($sfname.".rsc")
:log info message="Raw configuration script export Finished"
}

:local backupFileName ""
:local ftppath .$flocal

:foreach backupFile in=[/file find] do={
:set backupFileName ("/".[/file get $backupFile name])
:if ([:typeof [:find $backupFileName $sfname]] != "nil") do={
/tool fetch address=$FTPServer port=$FTPPort src-path=$backupFileName user=$FTPUser mode=ftp password=$FTPPass dst-path=$backupFileName upload=yes
}
}

:delay 5s

:foreach backupFile in=[/file find] do={
:if ([:typeof [:find [/file get $backupFile name] "BACKUP-"]]!="nil") do={
/file remove $backupFile
}
}

:log info message="Successfully removed Temporary Backup Files"
:log info message="Automatic Backup Completed Successfully"

[1] wikipedia 

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.